summaryrefslogtreecommitdiff
path: root/nrf-softdevice/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nrf-softdevice/Cargo.toml')
-rw-r--r--nrf-softdevice/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/nrf-softdevice/Cargo.toml b/nrf-softdevice/Cargo.toml
index 1c8f9ce..40f582c 100644
--- a/nrf-softdevice/Cargo.toml
+++ b/nrf-softdevice/Cargo.toml
@@ -28,7 +28,7 @@ ble-gatt = []
ble-gatt-server = ["ble-gatt"]
ble-gatt-client = ["ble-gatt"]
-critical-section-impl = ["critical-section/custom-impl"]
+critical-section-impl = ["critical-section-1/restore-state-bool", "critical-section-02/custom-impl"]
# Workaround l2cap credit bug. If set, infinite credits are issued
# to the peer in batches. The `credits` config when establishing the channel is ignored.
@@ -38,7 +38,8 @@ ble-l2cap-credit-wrokaround = []
[dependencies]
defmt = { version = "0.3", optional = true }
log = { version = "0.4.11", optional = true }
-critical-section = { version = "0.2.1" }
+critical-section-02 = { package = "critical-section", version = "0.2", optional = true }
+critical-section-1 = { package = "critical-section", version = "1.0", optional = true }
num_enum = { version = "0.5.1", default-features = false }
embassy-util = { version = "0.1.0" }