summaryrefslogtreecommitdiff
path: root/nrf-softdevice/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nrf-softdevice/Cargo.toml')
-rw-r--r--nrf-softdevice/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/nrf-softdevice/Cargo.toml b/nrf-softdevice/Cargo.toml
index 99dde0b..33ee0f0 100644
--- a/nrf-softdevice/Cargo.toml
+++ b/nrf-softdevice/Cargo.toml
@@ -29,6 +29,11 @@ ble-gatt-client = ["ble-gatt"]
critical-section-impl = ["critical-section/custom-impl"]
+# Workaround l2cap credit bug. If set, infinite credits are issued
+# to the peer in batches. The `credits` config when establishing the channel is ignored.
+# https://devzone.nordicsemi.com/f/nordic-q-a/81894/s140-7-3-0-softdevice-assertion-failed-at-pc-0xa806-using-l2cap
+ble-l2cap-credit-wrokaround = []
+
[dependencies]
defmt = { version = "0.3", optional = true }
log = { version = "0.4.11", optional = true }