summaryrefslogtreecommitdiff
path: root/nrf-softdevice/Cargo.toml
diff options
context:
space:
mode:
authoralexmoon <alex.r.moon@gmail.com>2022-08-17 16:09:09 -0600
committerGitHub <noreply@github.com>2022-08-17 16:09:09 -0600
commite1e4e2a2c2e9a8243368214fac02532e79c127a8 (patch)
tree6103e9dc1ca5d2a15c92fb016dc161d88a831e59 /nrf-softdevice/Cargo.toml
parenta0467c55b09c4b48f4f5a428f6ba56734804b638 (diff)
parentbeed7433fb8dd80e6a395034aa90613c5d6d74fd (diff)
downloadnrf-softdevice-e1e4e2a2c2e9a8243368214fac02532e79c127a8.zip
Merge pull request #129 from embassy-rs/cs
Update to critical-section 1.0
Diffstat (limited to 'nrf-softdevice/Cargo.toml')
-rw-r--r--nrf-softdevice/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/nrf-softdevice/Cargo.toml b/nrf-softdevice/Cargo.toml
index 1c8f9ce..40f582c 100644
--- a/nrf-softdevice/Cargo.toml
+++ b/nrf-softdevice/Cargo.toml
@@ -28,7 +28,7 @@ ble-gatt = []
ble-gatt-server = ["ble-gatt"]
ble-gatt-client = ["ble-gatt"]
-critical-section-impl = ["critical-section/custom-impl"]
+critical-section-impl = ["critical-section-1/restore-state-bool", "critical-section-02/custom-impl"]
# Workaround l2cap credit bug. If set, infinite credits are issued
# to the peer in batches. The `credits` config when establishing the channel is ignored.
@@ -38,7 +38,8 @@ ble-l2cap-credit-wrokaround = []
[dependencies]
defmt = { version = "0.3", optional = true }
log = { version = "0.4.11", optional = true }
-critical-section = { version = "0.2.1" }
+critical-section-02 = { package = "critical-section", version = "0.2", optional = true }
+critical-section-1 = { package = "critical-section", version = "1.0", optional = true }
num_enum = { version = "0.5.1", default-features = false }
embassy-util = { version = "0.1.0" }