summaryrefslogtreecommitdiff
path: root/nrf-softdevice/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2020-09-05 01:18:00 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2020-09-05 01:18:00 +0200
commit840e130a80b36eb53029ca7f0c115ea4aa7d19e3 (patch)
tree1708cb7a314f284c938d9314f8f517ac56fc132e /nrf-softdevice/Cargo.toml
parentace5776dcf6561ac8bbb25cc0a2ed6b373d581c5 (diff)
downloadnrf-softdevice-840e130a80b36eb53029ca7f0c115ea4aa7d19e3.zip
Add new nrf-softdevice crate, with just interrupts+flash for now.
Diffstat (limited to 'nrf-softdevice/Cargo.toml')
-rw-r--r--nrf-softdevice/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/nrf-softdevice/Cargo.toml b/nrf-softdevice/Cargo.toml
new file mode 100644
index 0000000..2fb0cf4
--- /dev/null
+++ b/nrf-softdevice/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "nrf-softdevice"
+version = "0.1.0"
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+
+[features]
+defmt-default = []
+defmt-trace = []
+defmt-debug = []
+defmt-info = []
+defmt-warn = []
+defmt-error = []
+
+[dependencies]
+async-flash = { version = "0.1.0", path = "../async-flash" }
+nrf-softdevice-s140 = { version = "0.1.1", path = "../nrf-softdevice-s140" }
+cortex-m = "0.6.2"
+cortex-m-rt = "0.6.12"
+bare-metal = { version = "0.2.0", features = ["const-fn"] }
+nrf52840-pac = { version = "0.9.0", features = ["rt"] }
+
+defmt = "0.1.0" \ No newline at end of file