summaryrefslogtreecommitdiff
path: root/nrf-softdevice/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2021-11-26 04:17:26 +0100
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2021-11-26 04:20:33 +0100
commit64deb3228950865b12a70bff9f1f01e5b4d1db10 (patch)
tree9489d55f26d26246ea67467f41856447b7b15dd8 /nrf-softdevice/Cargo.toml
parente8ee3a7cdc28eac8ce57a811ac01c75ccadbd839 (diff)
downloadnrf-softdevice-64deb3228950865b12a70bff9f1f01e5b4d1db10.zip
Use AtomicWaker instead of Signal for event handling.
It's slightly more lightweight!
Diffstat (limited to 'nrf-softdevice/Cargo.toml')
-rw-r--r--nrf-softdevice/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/nrf-softdevice/Cargo.toml b/nrf-softdevice/Cargo.toml
index 27ebf35..2f17e6b 100644
--- a/nrf-softdevice/Cargo.toml
+++ b/nrf-softdevice/Cargo.toml
@@ -40,6 +40,7 @@ cortex-m = "0.7.2"
cortex-m-rt = ">=0.6.15,<0.8"
heapless = "0.7.1"
fixed = "1.5.0"
+futures = { version = "0.3.17", default-features = false }
nrf52805-pac = { version = "0.10.0", features = ["rt"], optional = true }
nrf52810-pac = { version = "0.10.0", features = ["rt"], optional = true }