summaryrefslogtreecommitdiff
path: root/examples/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2021-05-10 00:24:24 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2021-05-10 00:24:24 +0200
commit8201255a9d6dde4b29a5a539a1d6aeefcbd467df (patch)
tree3366939a2c4b121091eb1abb3605f82e750b5c2f /examples/Cargo.toml
parent7e0bf163f35dca8a1daba11429035a7780f5f4b7 (diff)
downloadnrf-softdevice-8201255a9d6dde4b29a5a539a1d6aeefcbd467df.zip
Update embassy
Diffstat (limited to 'examples/Cargo.toml')
-rw-r--r--examples/Cargo.toml13
1 files changed, 1 insertions, 12 deletions
diff --git a/examples/Cargo.toml b/examples/Cargo.toml
index 09449c6..6b54d8a 100644
--- a/examples/Cargo.toml
+++ b/examples/Cargo.toml
@@ -28,23 +28,16 @@ embassy-traits = { version = "0.1.0", features = ["defmt"]}
embassy-nrf = { version = "0.1.0", features = [ "defmt", "52840" ]}
cortex-m = { version = "0.6.4" }
cortex-m-rt = "0.6.13"
-cortex-m-rtic = { version = "0.5.5", optional = true }
defmt = { version = "0.2.0", features = ["alloc"] }
nrf-softdevice-defmt-rtt = { path = "../nrf-softdevice-defmt-rtt", version = "0.1.0" }
panic-probe = "0.1.0"
-nrf52840-hal = { version = "0.12.0" }
-nrf-softdevice = { version = "0.1.0", path = "../nrf-softdevice", features = ["defmt", "defmt-trace", "nrf52840", "s140", "ble-peripheral", "ble-central"] }
+nrf-softdevice = { version = "0.1.0", path = "../nrf-softdevice", features = ["defmt", "defmt-trace", "nrf52840", "s140", "ble-peripheral", "ble-central", "critical-section-impl"] }
nrf-softdevice-s140 = { version = "0.1.1", path = "../nrf-softdevice-s140" }
futures = { version = "0.3.5", default-features = false }
fixed = "1.2.0"
heapless = "0.5.6"
alloc-cortex-m = "0.4.0"
-
-[[bin]]
-name = "rtic"
-required-features = ["cortex-m-rtic"]
-
[[bin]]
name = "ble_bas_peripheral"
required-features = ["ble-gatt-server"]
@@ -60,7 +53,3 @@ required-features = ["ble-gatt-server"]
[[bin]]
name = "flash"
required-features = []
-
-[[bin]]
-name = "interrupts"
-required-features = []