summaryrefslogtreecommitdiff
path: root/examples/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2020-09-14 17:47:43 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2020-09-14 17:47:43 +0200
commit1d840cf4b190397f5944ed1fb7e9007e5a2d82dc (patch)
tree5e259e4ee5234c6a9b5a8e382ef19b943c867fcf /examples/Cargo.toml
parentcb6771aceb53281797e578256a661ecbb1286f87 (diff)
downloadnrf-softdevice-1d840cf4b190397f5944ed1fb7e9007e5a2d82dc.zip
example -> examples
Diffstat (limited to 'examples/Cargo.toml')
-rw-r--r--examples/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/examples/Cargo.toml b/examples/Cargo.toml
new file mode 100644
index 0000000..49c5316
--- /dev/null
+++ b/examples/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+name = "nrf-softdevice-examples"
+version = "0.1.0"
+
+[features]
+default = [ "defmt-default" ]
+defmt-default = []
+defmt-trace = []
+defmt-debug = []
+defmt-info = []
+defmt-warn = []
+defmt-error = []
+
+[dependencies]
+async-flash = { version = "0.1.0", path = "../async-flash" }
+cortex-m = { version = "0.6.3" }
+cortex-m-rt = "0.6.12"
+cortex-m-rtic = { version = "0.5.5", optional = true }
+defmt = "0.1.0"
+defmt-rtt = "0.1.0"
+panic-probe = "0.1.0"
+nrf52840-hal = { version = "0.11.0" }
+nrf-softdevice = { version = "0.1.0", path = "../nrf-softdevice", features = ["defmt-trace", "nrf52840", "s140", "ble-peripheral", "ble-central"] }
+nrf-softdevice-s140 = { version = "0.1.1", path = "../nrf-softdevice-s140" }
+static-executor = { version = "0.1.0", features=["defmt"]}
+static-executor-cortex-m = { version = "0.1.0" }
+futures = { version = "0.3.5", default-features = false }
+
+[[bin]]
+name = "rtic"
+required-features = ["cortex-m-rtic"]
+