summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDario Nieuwenhuis <dirbaio@dirbaio.net>2021-08-18 23:45:36 +0200
committerDario Nieuwenhuis <dirbaio@dirbaio.net>2021-08-18 23:45:36 +0200
commitfca839c40f9651d84b8d6aa465b8e4169c2a0e76 (patch)
treed7b014d16f4b0b034651462530f57d3510dd68b8 /Cargo.toml
parent1094ac4d82c9c8eab75d3199a7da4e8db6d096b9 (diff)
downloadnrf-softdevice-fca839c40f9651d84b8d6aa465b8e4169c2a0e76.zip
Optimize CI
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 0 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bbba1e3..9be4480 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,14 +26,6 @@ embassy-nrf = { git = "https://github.com/embassy-rs/embassy" }
embassy-macros = { git = "https://github.com/embassy-rs/embassy" }
embassy-traits = { git = "https://github.com/embassy-rs/embassy" }
-[profile.dev]
-codegen-units = 1
-debug = 2
-debug-assertions = true
-incremental = false
-opt-level = 3
-overflow-checks = true
-
[profile.release]
codegen-units = 1
debug = 2
@@ -43,14 +35,6 @@ lto = "fat"
opt-level = 's'
overflow-checks = false
-# do not optimize proc-macro crates = faster builds from scratch
-[profile.dev.build-override]
-codegen-units = 8
-debug = false
-debug-assertions = false
-opt-level = 0
-overflow-checks = false
-
[profile.release.build-override]
codegen-units = 8
debug = false