summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2022-08-27 16:18:56 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2022-08-27 16:18:56 +0300
commit7650805c60cec2fe09cd2a59cb665731f5cca140 (patch)
tree754e6359daf491db61ab4c7a649394bb6f172494 /Cargo.toml
parente29041f73354c59ef95916edd75e6ca7876e3c3a (diff)
downloadmeli-7650805c60cec2fe09cd2a59cb665731f5cca140.zip
Bring stripped binary size down to 7MiB
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml46
1 files changed, 23 insertions, 23 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d45e1d9d..6570a04d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,42 +26,42 @@ path = "src/main.rs"
#path = "src/async.rs"
[dependencies]
-xdg = "2.1.0"
-crossbeam = "^0.8"
-signal-hook = "^0.3"
-signal-hook-registry = "1.2.0"
-nix = "^0.24"
+async-task = "^4.2.0"
+bincode = { version = "^1.3.0", default-features = false }
+bitflags = "1.0"
+crossbeam = { version = "^0.8" }
+flate2 = { version = "1.0.16", optional = true }
+futures = "0.3.5"
+indexmap = { version = "^1.6", features = ["serde-1", ] }
+libc = { version = "0.2.125", default-features = false, features = ["extra_traits",] }
+linkify = { version = "^0.8", default-features = false }
melib = { path = "melib", version = "0.7.2" }
+nix = { version = "^0.24", default-features = false }
+notify = { version = "4.0.1", default-features = false } # >:c
+num_cpus = "1.12.0"
+pcre2 = { version = "0.2.3", optional = true }
serde = "1.0.71"
serde_derive = "1.0.71"
serde_json = "1.0"
-toml = { version = "0.5.6", features = ["preserve_order", ] }
-indexmap = { version = "^1.6", features = ["serde-1", ] }
-linkify = "^0.8"
-notify = "4.0.1" # >:c
-termion = "1.5.1"
-bincode = "^1.3.0"
-unicode-segmentation = "1.2.1" # >:c
-libc = {version = "0.2.125", features = ["extra_traits",]}
+signal-hook = { version = "^0.3", default-features = false }
+signal-hook-registry = { version = "1.2.0", default-features = false }
smallvec = { version = "^1.5.0", features = ["serde", ] }
-bitflags = "1.0"
-pcre2 = { version = "0.2.3", optional = true }
structopt = { version = "0.3.14", default-features = false }
svg_crate = { version = "^0.10", optional = true, package = "svg" }
-futures = "0.3.5"
-async-task = "^4.2.0"
-num_cpus = "1.12.0"
-flate2 = { version = "1.0.16", optional = true }
+termion = { version = "1.5.1", default-features = false }
+toml = { version = "0.5.6", default-features = false, features = ["preserve_order", ] }
+unicode-segmentation = "1.2.1" # >:c
+xdg = "2.1.0"
[target.'cfg(target_os="linux")'.dependencies]
-notify-rust = { version = "^4", optional = true }
+notify-rust = { version = "^4", default-features = false, features = ["dbus", ], optional = true }
[build-dependencies]
-syn = { version = "1.0.92", features = [] }
-quote = "^1.0"
-proc-macro2 = "1.0.37"
flate2 = { version = "1.0.16", optional = true }
+proc-macro2 = "1.0.37"
+quote = "^1.0"
+syn = { version = "1.0.92", features = [] }
[dev-dependencies]
regex = "1"