summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2022-05-02 15:44:39 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2022-05-02 17:03:56 +0300
commit2c23ca34cdee769a0f78a0b0ef934e5f20dd9567 (patch)
tree7a1848d42e0e519c5042a95d60363eeed3cd862c /Cargo.toml
parent2eb22a290abb3f37bc77c3bc2771edfb60a1c314 (diff)
downloadmeli-2c23ca34cdee769a0f78a0b0ef934e5f20dd9567.zip
Update most Cargo dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 9 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b9563d2a..780c79c5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,10 +27,10 @@ path = "src/bin.rs"
[dependencies]
xdg = "2.1.0"
-crossbeam = "0.7.2"
-signal-hook = "0.1.12"
+crossbeam = "^0.8"
+signal-hook = "^0.3"
signal-hook-registry = "1.2.0"
-nix = "0.17.0"
+nix = "^0.24"
melib = { path = "melib", version = "0.7.2" }
serde = "1.0.71"
@@ -38,20 +38,19 @@ serde_derive = "1.0.71"
serde_json = "1.0"
toml = { version = "0.5.6", features = ["preserve_order", ] }
indexmap = { version = "^1.6", features = ["serde-1", ] }
-linkify = "0.4.0"
+linkify = "^0.8"
notify = "4.0.1" # >:c
termion = "1.5.1"
bincode = "^1.3.0"
-uuid = { version = "0.8.1", features = ["serde", "v4"] }
unicode-segmentation = "1.2.1" # >:c
-libc = {version = "0.2.59", features = ["extra_traits",]}
+libc = {version = "0.2.125", features = ["extra_traits",]}
smallvec = { version = "^1.5.0", features = ["serde", ] }
bitflags = "1.0"
pcre2 = { version = "0.2.3", optional = true }
structopt = { version = "0.3.14", default-features = false }
-svg_crate = { version = "0.8.0", optional = true, package = "svg" }
+svg_crate = { version = "^0.10", optional = true, package = "svg" }
futures = "0.3.5"
-async-task = "3.0.0"
+async-task = "^4.2.0"
num_cpus = "1.12.0"
flate2 = { version = "1.0.16", optional = true }
@@ -59,9 +58,9 @@ flate2 = { version = "1.0.16", optional = true }
notify-rust = { version = "^4", optional = true }
[build-dependencies]
-syn = { version = "1.0.31", features = [] }
+syn = { version = "1.0.92", features = [] }
quote = "^1.0"
-proc-macro2 = "1.0.18"
+proc-macro2 = "1.0.37"
flate2 = { version = "1.0.16", optional = true }
[dev-dependencies]