summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--debian/changelog11
-rw-r--r--debian/compat1
-rw-r--r--debian/control25
-rw-r--r--debian/copyright31
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs3
-rwxr-xr-xdebian/rules92
8 files changed, 167 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index eeddc1d..73ccb76 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ LDFLAGS+=-L/usr/local/lib -lxcb -lxcb-randr -lxcb-keysyms -lxcb-icccm \
-lxcb-util #-ldmalloc
RM=/bin/rm
-PREFIX=/usr/local
+PREFIX=$(DESTDIR)
TARGETS=mcwm hidden
OBJS=mcwm.o list.o
@@ -31,6 +31,7 @@ list.o: list.c list.h Makefile
install: $(TARGETS)
install -m 755 mcwm $(PREFIX)/bin
+ install -m 755 -d $(PREFIX)/man/man1/
install -m 644 mcwm.man $(PREFIX)/man/man1/mcwm.1
install -m 755 hidden $(PREFIX)/bin
install -m 644 hidden.man $(PREFIX)/man/man1/hidden.1
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..99e549c
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+mcwm (0git20111117) unstable; urgency=low
+
+ * Rebase to 20111117.
+
+ -- cos <cos> Fri, 18 Nov 2011 00:03:04 +0100
+
+mcwm (0git20101204) unstable; urgency=low
+
+ * Initial Release.
+
+ -- cos <cos> Sat, 04 Dec 2010 22:18:12 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..46a1df5
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: mcwm
+Section: unknown
+Priority: extra
+Maintainer: cos <cos>
+Build-Depends: debhelper (>= 7), libxcb1-dev, libxcb-atom1-dev, libxcb-keysyms1-dev, libxcb-icccm1-dev, libxcb-randr0-dev
+Standards-Version: 3.7.3
+Homepage: http://www.hack.org/mc/hacks/mcwm/
+
+Package: mcwm
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: The name “mcwm” comes from ”MC's Window Manager”
+ This is a window manager for the X Window System written entirely with
+ XCB, the straight X protocol binding to the C language. It doesn't use
+ libX11 at all.
+ .
+ It's a minimalistic, floating window manager. The only window
+ decoration is a thin border. All functions can be done with the
+ keyboard, but moving, resizing, raising and lowering can also be done
+ with the mouse.
+ .
+ If you don't like the default key bindings, border width, et cetera,
+ look in the config.h file, change and recompile.
+ .
+ See the manual page for how to use it.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..bc65530
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,31 @@
+This package was debianized by cos <cos> on Sat, 04 Dec 2010 22:18:12 +0100.
+
+It was downloaded from http://www.hack.org/mc/hacks/mcwm/
+
+Upstream Author:
+
+ Michael Cardell Widerkrantz, <mc@hack.org>.
+
+Copyright:
+
+ Copyright (c) 2010 Michael Cardell Widerkrantz
+
+License:
+
+ Permission to use, copy, modify, and distribute this software for any
+ purpose with or without fee is hereby granted, provided that the above
+ copyright notice and this permission notice appear in all copies.
+
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL
+ WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED
+ WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE
+ AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
+ DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
+ PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+ TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+ PERFORMANCE OF THIS SOFTWARE.
+
+The Debian packaging is (C) 2010-2011, cos <cos> and is licensed under the ISC
+license, see `http://www.isc.org/software/license'.
+
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..5502ed8
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,3 @@
+NEWS
+README
+TODO
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a24dd6d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,92 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/mcwm.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/mcwm/usr install
+ install -d $(CURDIR)/debian/mcwm/usr/share/man/man1/
+ install mcwm.man $(CURDIR)/debian/mcwm/usr/share/man/man1/mcwm.1
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure