summaryrefslogtreecommitdiff
path: root/tests/rp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tests/rp/Cargo.toml')
-rw-r--r--tests/rp/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/rp/Cargo.toml b/tests/rp/Cargo.toml
index 50337375..d6770d6e 100644
--- a/tests/rp/Cargo.toml
+++ b/tests/rp/Cargo.toml
@@ -2,6 +2,7 @@
edition = "2021"
name = "embassy-rp-tests"
version = "0.1.0"
+license = "MIT OR Apache-2.0"
[dependencies]
embassy-sync = { version = "0.1.0", path = "../../embassy-sync", features = ["defmt"] }
@@ -16,8 +17,8 @@ defmt-rtt = "0.3.0"
cortex-m = { version = "0.7.6", features = ["critical-section-single-core"] }
cortex-m-rt = "0.7.0"
embedded-hal = "0.2.6"
-embedded-hal-1 = { package = "embedded-hal", version = "1.0.0-alpha.8" }
-embedded-hal-async = { version = "0.1.0-alpha.1" }
+embedded-hal-1 = { package = "embedded-hal", version = "=1.0.0-alpha.9" }
+embedded-hal-async = { version = "=0.1.0-alpha.2" }
panic-probe = { version = "0.3.0", features = ["print-defmt"] }
futures = { version = "0.3.17", default-features = false, features = ["async-await"] }
embedded-io = { version = "0.3.0", features = ["async"] }