summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLee Garrett <lgarrett@rocketjump.eu>2023-08-18 23:13:06 +0200
committerLee Garrett <lgarrett@rocketjump.eu>2023-08-18 23:48:20 +0200
commit5fe9f3b75b9aab0bb3c9a9643b2ddd8f0adfa3cb (patch)
tree69a0a697fda7a6f305e27d4b4c122e8e0c319055
parent09ab3182f34f714c9abc4757a358c612f9384eb6 (diff)
downloaddebian-ansible-core-5fe9f3b75b9aab0bb3c9a9643b2ddd8f0adfa3cb.zip
Refresh patches
-rw-r--r--debian/patches/0005-use-py3.patch38
-rw-r--r--debian/patches/0009-resolvelib_compat.patch45
2 files changed, 16 insertions, 67 deletions
diff --git a/debian/patches/0005-use-py3.patch b/debian/patches/0005-use-py3.patch
index 04ba2a3b..566db4f8 100644
--- a/debian/patches/0005-use-py3.patch
+++ b/debian/patches/0005-use-py3.patch
@@ -8,14 +8,6 @@ Last-Update: 2021-11-06
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/docs/bin/find-plugin-refs.py
-+++ b/docs/bin/find-plugin-refs.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- # To run this script, first make webdocs in the toplevel of the checkout. This will generate all
- # rst files from their sources. Then run this script ./docs/bin/find-plugin-refs.py
--- a/lib/ansible/cli/scripts/ansible_connection_cli_stub.py
+++ b/lib/ansible/cli/scripts/ansible_connection_cli_stub.py
@@ -1,4 +1,4 @@
@@ -24,14 +16,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
# Copyright: (c) 2017, Ansible Project
# GNU General Public License v3.0+ (see COPYING or https://www.gnu.org/licenses/gpl-3.0.txt)
from __future__ import (absolute_import, division, print_function)
---- a/packaging/sdist/check-link-behavior.py
-+++ b/packaging/sdist/check-link-behavior.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Checks for link behavior required for sdist to retain symlinks."""
-
- from __future__ import (absolute_import, division, print_function)
--- a/test/integration/targets/cli/test-cli.py
+++ b/test/integration/targets/cli/test-cli.py
@@ -1,4 +1,4 @@
@@ -250,25 +234,3 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
'import sys',
'sys.stderr.write("stderr stuff")',
"print('%s')" % json.dumps(module_result)
---- a/Makefile
-+++ b/Makefile
-@@ -26,7 +26,7 @@
- ASCII2MAN = @echo "ERROR: rst2man from docutils command is not installed but is required to build $(MANPAGES)" && exit 1
- endif
-
--PYTHON ?= python
-+PYTHON ?= python3
- GENERATE_CLI = packaging/pep517_backend/_generate_man.py
-
- # fetch version from project release.py as single source-of-truth
---- a/docs/docsite/Makefile
-+++ b/docs/docsite/Makefile
-@@ -44,7 +44,7 @@
-
- DOC_PLUGINS ?= become cache callback cliconf connection httpapi inventory lookup netconf shell strategy vars
-
--PYTHON ?= python
-+PYTHON ?= python3
- # fetch version from project release.py as single source-of-truth
- VERSION := $(shell $(PYTHON) ../../packaging/release/versionhelper/version_helper.py --raw || echo error)
- ifeq ($(findstring error,$(VERSION)), error)
diff --git a/debian/patches/0009-resolvelib_compat.patch b/debian/patches/0009-resolvelib_compat.patch
index 24339cec..b1d0331b 100644
--- a/debian/patches/0009-resolvelib_compat.patch
+++ b/debian/patches/0009-resolvelib_compat.patch
@@ -1,4 +1,4 @@
-Description: ansible-galaxy - support resolvelib >= 0.5.3, < 0.10.0
+Description: ansible-galaxy - support resolvelib >= 0.5.3, < 1.1.0
Author: Wong Hoi Sing Edison <hswong3i@gmail.com>
Origin: upstream, https://github.com/ansible/ansible/pull/80196
Applied-Upstream: yes
@@ -10,7 +10,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+++ b/changelogs/fragments/79399-resolvelib_lt_0_10_0.yml
@@ -0,0 +1,2 @@
+minor_changes:
-+ - ansible-galaxy - support ``resolvelib >= 0.5.3, < 0.10.0``.
++ - ansible-galaxy - support ``resolvelib >= 0.5.3, < 1.1.0``.
--- a/lib/ansible/galaxy/dependency_resolution/providers.py
+++ b/lib/ansible/galaxy/dependency_resolution/providers.py
@@ -40,7 +40,7 @@
@@ -47,46 +47,33 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
# NOTE: in the ansible-galaxy-collection test suite.
-resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
+resolvelib >= 0.5.3, < 1.1.0 # dependency resolver used by ansible-galaxy
---- a/test/sanity/code-smell/docs-build.requirements.in
-+++ b/test/sanity/code-smell/docs-build.requirements.in
-@@ -1,6 +1,6 @@
- jinja2
- pyyaml
--resolvelib < 0.9.0
-+resolvelib < 1.1.0
- sphinx == 4.2.0
- sphinx-notfound-page
- sphinx-ansible-theme
---- a/test/sanity/code-smell/docs-build.requirements.txt
-+++ b/test/sanity/code-smell/docs-build.requirements.txt
-@@ -27,7 +27,7 @@
- pytz==2022.2.1
- PyYAML==6.0
- requests==2.28.1
--resolvelib==0.8.1
-+resolvelib < 1.1.0
- rstcheck==3.5.0
- semantic-version==2.10.0
- sh==1.14.3
--- a/test/sanity/code-smell/package-data.requirements.in
+++ b/test/sanity/code-smell/package-data.requirements.in
-@@ -1,7 +1,7 @@
- docutils < 0.18 # match version required by sphinx in the docs-build sanity test
+@@ -2,7 +2,7 @@
+ wheel # required to build wheel
jinja2
pyyaml # ansible-core requirement
-resolvelib < 0.9.0
+resolvelib < 1.1.0
rstcheck < 4 # match version used in other sanity tests
- straight.plugin
antsibull-changelog
+ setuptools == 45.2.0 # minimum supported setuptools
--- a/test/sanity/code-smell/package-data.requirements.txt
+++ b/test/sanity/code-smell/package-data.requirements.txt
-@@ -6,7 +6,7 @@
- packaging==21.3
+@@ -10,7 +10,7 @@
+ pyproject_hooks==1.0.0
pyparsing==3.0.9
PyYAML==6.0
-resolvelib==0.8.1
+resolvelib==1.0.1
rstcheck==3.5.0
semantic-version==2.10.0
- straight.plugin==1.5.0
+ setuptools==45.2.0
+--- a/lib/ansible_core.egg-info/requires.txt
++++ b/lib/ansible_core.egg-info/requires.txt
+@@ -2,4 +2,4 @@
+ PyYAML>=5.1
+ cryptography
+ packaging
+-resolvelib<0.9.0,>=0.5.3
++resolvelib<1.1.0,>=0.5.3