summaryrefslogtreecommitdiff
path: root/src/protocols/irc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/protocols/irc/Makefile.am')
-rw-r--r--src/protocols/irc/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/protocols/irc/Makefile.am b/src/protocols/irc/Makefile.am
new file mode 100644
index 000000000..2670aca85
--- /dev/null
+++ b/src/protocols/irc/Makefile.am
@@ -0,0 +1,31 @@
+# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(GNUTLS_CFLAGS)
+
+noinst_LIBRARIES = lib_weechat_irc.a
+
+lib_weechat_irc_a_SOURCES = irc.h \
+ irc-commands.c \
+ irc-send.c \
+ irc-recv.c \
+ irc-server.c \
+ irc-channel.c \
+ irc-nick.c \
+ irc-mode.c \
+ irc-dcc.c \
+ irc-ignore.c \
+ irc-display.c