summaryrefslogtreecommitdiff
path: root/src/plugins/demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/demo/CMakeLists.txt')
-rw-r--r--src/plugins/demo/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/plugins/demo/CMakeLists.txt b/src/plugins/demo/CMakeLists.txt
new file mode 100644
index 000000000..a8ed8da0a
--- /dev/null
+++ b/src/plugins/demo/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+ADD_LIBRARY(demo MODULE demo.c demo.h)
+SET_TARGET_PROPERTIES(demo PROPERTIES PREFIX "")
+
+TARGET_LINK_LIBRARIES(demo)
+
+INSTALL(TARGETS demo LIBRARY DESTINATION lib/${PROJECT_NAME}/plugins)