summaryrefslogtreecommitdiff
path: root/Userland/Services/WebContent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Services/WebContent/CMakeLists.txt')
-rw-r--r--Userland/Services/WebContent/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Userland/Services/WebContent/CMakeLists.txt b/Userland/Services/WebContent/CMakeLists.txt
new file mode 100644
index 0000000000..a7e367ff94
--- /dev/null
+++ b/Userland/Services/WebContent/CMakeLists.txt
@@ -0,0 +1,13 @@
+compile_ipc(WebContentServer.ipc WebContentServerEndpoint.h)
+compile_ipc(WebContentClient.ipc WebContentClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ main.cpp
+ PageHost.cpp
+ WebContentServerEndpoint.h
+ WebContentClientEndpoint.h
+)
+
+serenity_bin(WebContent)
+target_link_libraries(WebContent LibCore LibIPC LibGfx LibWeb)