summaryrefslogtreecommitdiff
path: root/Userland/Services/NotificationServer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Services/NotificationServer/CMakeLists.txt')
-rw-r--r--Userland/Services/NotificationServer/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Userland/Services/NotificationServer/CMakeLists.txt b/Userland/Services/NotificationServer/CMakeLists.txt
index a28d9f16a5..fc59c4d4e0 100644
--- a/Userland/Services/NotificationServer/CMakeLists.txt
+++ b/Userland/Services/NotificationServer/CMakeLists.txt
@@ -1,3 +1,9 @@
+serenity_component(
+ NotificationServer
+ REQUIRED
+ TARGETS NotificationServer
+)
+
compile_ipc(NotificationServer.ipc NotificationServerEndpoint.h)
compile_ipc(NotificationClient.ipc NotificationClientEndpoint.h)