summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibSystem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Libraries/LibSystem/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibSystem/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/Userland/Libraries/LibSystem/CMakeLists.txt b/Userland/Libraries/LibSystem/CMakeLists.txt
index a376338226..61ffa0622f 100644
--- a/Userland/Libraries/LibSystem/CMakeLists.txt
+++ b/Userland/Libraries/LibSystem/CMakeLists.txt
@@ -1,13 +1,7 @@
set(SOURCES
- Wrappers.cpp
syscall.cpp
)
-# FIXME: This is a hack to avoid a circular dependency with LibC. Figure out a better way.
-if ("${SERENITY_ARCH}" STREQUAL "i686")
- set_source_files_properties(${SOURCES} PROPERTIES COMPILE_FLAGS "-fno-stack-protector")
-endif()
-
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdlib")
serenity_libc(LibSystem system)
target_include_directories(LibSystem PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})