summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibPthread/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Libraries/LibPthread/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibPthread/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Userland/Libraries/LibPthread/CMakeLists.txt b/Userland/Libraries/LibPthread/CMakeLists.txt
new file mode 100644
index 0000000000..c8644e0868
--- /dev/null
+++ b/Userland/Libraries/LibPthread/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(SOURCES
+ pthread.cpp
+ pthread_once.cpp
+)
+
+serenity_libc(LibPthread pthread)
+target_link_libraries(LibPthread LibC)
+target_include_directories(LibPthread PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})