summaryrefslogtreecommitdiff
path: root/Userland/DevTools/GMLPlayground/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/DevTools/GMLPlayground/CMakeLists.txt')
-rw-r--r--Userland/DevTools/GMLPlayground/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Userland/DevTools/GMLPlayground/CMakeLists.txt b/Userland/DevTools/GMLPlayground/CMakeLists.txt
index ed493dfa7d..8b91442fc7 100644
--- a/Userland/DevTools/GMLPlayground/CMakeLists.txt
+++ b/Userland/DevTools/GMLPlayground/CMakeLists.txt
@@ -4,9 +4,15 @@ serenity_component(
TARGETS GMLPlayground
)
+compile_gml(GMLPlaygroundWindow.gml GMLPlaygroundWindowGML.h gml_playground_window_gml)
+
set(SOURCES
main.cpp
)
+set(GENERATED_SOURCES
+ GMLPlaygroundWindowGML.h
+)
+
serenity_app(GMLPlayground ICON app-gml-playground)
target_link_libraries(GMLPlayground PRIVATE LibCore LibDesktop LibFileSystemAccessClient LibGfx LibGUI LibMain LibSyntax)