summaryrefslogtreecommitdiff
path: root/Userland/Demos/WidgetGallery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Demos/WidgetGallery/CMakeLists.txt')
-rw-r--r--Userland/Demos/WidgetGallery/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Userland/Demos/WidgetGallery/CMakeLists.txt b/Userland/Demos/WidgetGallery/CMakeLists.txt
index 4fb67e3285..69179e26a2 100644
--- a/Userland/Demos/WidgetGallery/CMakeLists.txt
+++ b/Userland/Demos/WidgetGallery/CMakeLists.txt
@@ -1,8 +1,21 @@
+compile_gml(./GalleryGML/Window.gml WindowGML.h window_gml)
+compile_gml(./GalleryGML/BasicsTab.gml BasicsTabGML.h basics_tab_gml)
+compile_gml(./GalleryGML/SlidersTab.gml SlidersTabGML.h sliders_tab_gml)
+compile_gml(./GalleryGML/CursorsTab.gml CursorsTabGML.h cursors_tab_gml)
+compile_gml(./GalleryGML/IconsTab.gml IconsTabGML.h icons_tab_gml)
+compile_gml(./GalleryGML/WizardsTab.gml WizardsTabGML.h wizards_tab_gml)
compile_gml(DemoWizardPage1.gml DemoWizardPage1GML.h demo_wizard_page_1_gml)
compile_gml(DemoWizardPage2.gml DemoWizardPage2GML.h demo_wizard_page_2_gml)
set(SOURCES
main.cpp
+ GalleryWidget.cpp
+ WindowGML.h
+ BasicsTabGML.h
+ SlidersTabGML.h
+ CursorsTabGML.h
+ IconsTabGML.h
+ WizardsTabGML.h
DemoWizardDialog.cpp
DemoWizardPage1GML.h
DemoWizardPage2GML.h