summaryrefslogtreecommitdiff
path: root/Userland/Applications/Browser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Userland/Applications/Browser/CMakeLists.txt')
-rw-r--r--Userland/Applications/Browser/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/Userland/Applications/Browser/CMakeLists.txt b/Userland/Applications/Browser/CMakeLists.txt
new file mode 100644
index 0000000000..4652ec8b11
--- /dev/null
+++ b/Userland/Applications/Browser/CMakeLists.txt
@@ -0,0 +1,19 @@
+compile_gml(BrowserWindow.gml BrowserWindowGML.h browser_window_gml)
+compile_gml(Tab.gml TabGML.h tab_gml)
+
+set(SOURCES
+ BookmarksBarWidget.cpp
+ BrowserConsoleClient.cpp
+ ConsoleWidget.cpp
+ DownloadWidget.cpp
+ History.cpp
+ InspectorWidget.cpp
+ main.cpp
+ Tab.cpp
+ WindowActions.cpp
+ BrowserWindowGML.h
+ TabGML.h
+)
+
+serenity_app(Browser ICON app-browser)
+target_link_libraries(Browser LibWeb LibProtocol LibGUI LibDesktop)