summaryrefslogtreecommitdiff
path: root/Tests/LibRegex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LibRegex/CMakeLists.txt')
-rw-r--r--Tests/LibRegex/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/Tests/LibRegex/CMakeLists.txt b/Tests/LibRegex/CMakeLists.txt
index 1b81dcf482..eeeacecfba 100644
--- a/Tests/LibRegex/CMakeLists.txt
+++ b/Tests/LibRegex/CMakeLists.txt
@@ -1,5 +1,9 @@
-file(GLOB TEST_SOURCES CONFIGURE_DEPENDS "*.cpp")
+set(TEST_SOURCES
+ Benchmark.cpp
+ Regex.cpp
+ RegexLibC.cpp
+)
-foreach(source ${TEST_SOURCES})
- serenity_test(${source} LibRegex LIBS LibRegex)
+foreach(source IN LISTS TEST_SOURCES)
+ serenity_test("${source}" LibRegex LIBS LibRegex)
endforeach()