summaryrefslogtreecommitdiff
path: root/Tests/LibMarkdown/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LibMarkdown/CMakeLists.txt')
-rw-r--r--Tests/LibMarkdown/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/Tests/LibMarkdown/CMakeLists.txt b/Tests/LibMarkdown/CMakeLists.txt
index a9c5d179a1..b69c3013b1 100644
--- a/Tests/LibMarkdown/CMakeLists.txt
+++ b/Tests/LibMarkdown/CMakeLists.txt
@@ -1,6 +1,9 @@
include(${SERENITY_PROJECT_ROOT}/Meta/CMake/commonmark_spec.cmake)
-file(GLOB TEST_SOURCES CONFIGURE_DEPENDS "*.cpp")
-foreach(source ${TEST_SOURCES})
- serenity_test(${source} LibMarkdown LIBS LibMarkdown)
+set(TEST_SOURCES
+ TestCommonmark.cpp
+)
+
+foreach(source IN LISTS TEST_SOURCES)
+ serenity_test("${source}" LibMarkdown LIBS LibMarkdown)
endforeach()