summaryrefslogtreecommitdiff
path: root/Tests/LibCrypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LibCrypto/CMakeLists.txt')
-rw-r--r--Tests/LibCrypto/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/Tests/LibCrypto/CMakeLists.txt b/Tests/LibCrypto/CMakeLists.txt
index e376215ab1..cc14627b0a 100644
--- a/Tests/LibCrypto/CMakeLists.txt
+++ b/Tests/LibCrypto/CMakeLists.txt
@@ -1,4 +1,12 @@
-file(GLOB TEST_SOURCES CONFIGURE_DEPENDS "*.cpp")
-foreach(source ${TEST_SOURCES})
- serenity_test(${source} LibCrypto LIBS LibCrypto)
+set(TEST_SOURCES
+ TestAES.cpp
+ TestBigInteger.cpp
+ TestChecksum.cpp
+ TestHash.cpp
+ TestHMAC.cpp
+ TestRSA.cpp
+)
+
+foreach(source IN LISTS TEST_SOURCES)
+ serenity_test("${source}" LibCrypto LIBS LibCrypto)
endforeach()