summaryrefslogtreecommitdiff
path: root/Tests/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Kernel/CMakeLists.txt')
-rw-r--r--Tests/Kernel/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/Kernel/CMakeLists.txt b/Tests/Kernel/CMakeLists.txt
index a91b4e0979..d411a8091c 100644
--- a/Tests/Kernel/CMakeLists.txt
+++ b/Tests/Kernel/CMakeLists.txt
@@ -25,11 +25,13 @@ set(TEST_SOURCES
foreach(source IN LISTS TEST_SOURCES)
get_filename_component(test_name "${source}" NAME_WE)
add_executable("${test_name}" "${source}")
- target_link_libraries("${test_name}" LibCore)
+ target_link_libraries("${test_name}" PRIVATE LibCore)
serenity_set_implicit_links("${test_name}")
install(TARGETS "${test_name}" RUNTIME DESTINATION usr/Tests/Kernel/Legacy)
endforeach()
+target_link_libraries(fuzz-syscalls PRIVATE LibSystem)
+
serenity_test("crash.cpp" Kernel MAIN_ALREADY_DEFINED)
set(LIBTEST_BASED_SOURCES