summaryrefslogtreecommitdiff
path: root/Services/ImageDecoder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Services/ImageDecoder/CMakeLists.txt')
-rw-r--r--Services/ImageDecoder/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Services/ImageDecoder/CMakeLists.txt b/Services/ImageDecoder/CMakeLists.txt
new file mode 100644
index 0000000000..ce9ad077fc
--- /dev/null
+++ b/Services/ImageDecoder/CMakeLists.txt
@@ -0,0 +1,12 @@
+compile_ipc(ImageDecoderServer.ipc ImageDecoderServerEndpoint.h)
+compile_ipc(ImageDecoderClient.ipc ImageDecoderClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ main.cpp
+ ImageDecoderServerEndpoint.h
+ ImageDecoderClientEndpoint.h
+)
+
+serenity_bin(ImageDecoder)
+target_link_libraries(ImageDecoder LibIPC LibGfx)