summaryrefslogtreecommitdiff
path: root/Ladybird/ladybird.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Ladybird/ladybird.nix')
-rw-r--r--Ladybird/ladybird.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/Ladybird/ladybird.nix b/Ladybird/ladybird.nix
new file mode 100644
index 0000000000..c5a038b529
--- /dev/null
+++ b/Ladybird/ladybird.nix
@@ -0,0 +1,23 @@
+{ pkgs ? import <nixpkgs> { } }:
+pkgs.mkShell.override
+{
+ stdenv = pkgs.gcc12Stdenv;
+}
+{
+ name = "ladybird";
+
+ nativeBuildInputs = with pkgs; [
+ pkgconfig
+ cmake
+ ninja
+ qt6.qtbase
+ qt6.qtbase.dev
+ qt6.qttools
+ qt6.qtwayland
+ qt6.qtwayland.dev
+ ];
+
+ shellHook = ''
+ export QT_QPA_PLATFORM="wayland;xcb"
+ '';
+}