summaryrefslogtreecommitdiff
path: root/Userland/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Biscaro <marcobiscaro2112@gmail.com>2021-04-17 23:20:56 -0300
committerLinus Groh <mail@linusgroh.de>2021-04-21 08:00:32 +0200
commit8124719c3d2744edfc475155f70a286cb45e72ef (patch)
tree8f024eab41bbec679645044ff7329ef08900a73f /Userland/Utilities/CMakeLists.txt
parent78733417a471a02567e5cb24506d4003110c44b1 (diff)
downloadserenity-8124719c3d2744edfc475155f70a286cb45e72ef.zip
Tests: Reorganize LibCompress unit tests
Move LibCompress unit tests to LibCompress/Tests directory and register them with CMake's add_test. This allows us to run these tests with ninja test instead of running a separate executable. Also split the existing tests in 3 test files that better follow the source code structure (inspired by AK tests).
Diffstat (limited to 'Userland/Utilities/CMakeLists.txt')
-rw-r--r--Userland/Utilities/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Userland/Utilities/CMakeLists.txt b/Userland/Utilities/CMakeLists.txt
index 999a98151b..1b0c424049 100644
--- a/Userland/Utilities/CMakeLists.txt
+++ b/Userland/Utilities/CMakeLists.txt
@@ -43,7 +43,6 @@ target_link_libraries(su LibCrypt)
target_link_libraries(tar LibArchive LibCompress)
target_link_libraries(telws LibCrypto LibTLS LibWebSocket LibLine)
target_link_libraries(test-crypto LibCrypto LibTLS LibLine)
-target_link_libraries(test-compress LibCompress)
target_link_libraries(test-fuzz LibCore LibGemini LibGfx LibHTTP LibIPC LibJS LibMarkdown LibShell)
target_link_libraries(test-js LibJS LibLine LibCore)
target_link_libraries(test-pthread LibThread)