summaryrefslogtreecommitdiff
path: root/Userland/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-07-14 21:49:26 +0200
committerAndreas Kling <kling@serenityos.org>2022-07-14 23:27:19 +0200
commited9b2a85edfb042bba1297c77be9d7b52422b0ce (patch)
treebb47867d830d164e258e386b109e269922162a10 /Userland/Utilities/CMakeLists.txt
parent976562b8176de1deaa0b420a0b3a9075a34d08cd (diff)
downloadserenity-ed9b2a85edfb042bba1297c77be9d7b52422b0ce.zip
Utilities: Add "pledge" utility for launching a sandboxed command
This new command allows you to run any command with an initial set of pledge promises. Note that dynamically linked executables won't be able to bootstrap without at least "stdio rpath prot_exec". Inspired by http://justine.lol/pledge/ :^)
Diffstat (limited to 'Userland/Utilities/CMakeLists.txt')
-rw-r--r--Userland/Utilities/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Utilities/CMakeLists.txt b/Userland/Utilities/CMakeLists.txt
index a90eec5537..f3b51a1115 100644
--- a/Userland/Utilities/CMakeLists.txt
+++ b/Userland/Utilities/CMakeLists.txt
@@ -175,6 +175,7 @@ target_link_libraries(pathchk LibMain)
target_link_libraries(pgrep LibRegex LibMain)
target_link_libraries(pidof LibMain)
target_link_libraries(ping LibMain)
+target_link_libraries(pledge LibMain)
target_link_libraries(pls LibCrypt LibMain)
target_link_libraries(pmap LibMain)
target_link_libraries(pmemdump LibMain)