summaryrefslogtreecommitdiff
path: root/Userland/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorValtteri Koskivuori <vkoskiv@gmail.com>2021-05-03 21:49:11 +0300
committerLinus Groh <mail@linusgroh.de>2021-05-07 11:46:53 +0100
commit8b2706e5bb8773d3df10a28161578cbe61098f0e (patch)
treeef913105277654041692346cef61443c0203345c /Userland/Utilities/CMakeLists.txt
parentcf5f3a98741e531e26fe66e9793f265d633c2caa (diff)
downloadserenity-8b2706e5bb8773d3df10a28161578cbe61098f0e.zip
Userland: Implement a file utility
This unix classic attempts to classify and identify information about given files based on various heuristics. In this case, we're relying on the Core::MimeData detector for file type and LibGfx::ImageDecoder for additional metadata if the given file is an image. It's very simple for now, but adding new detectors should be quite easy.
Diffstat (limited to 'Userland/Utilities/CMakeLists.txt')
-rw-r--r--Userland/Utilities/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Utilities/CMakeLists.txt b/Userland/Utilities/CMakeLists.txt
index dbdfd42856..429107fca5 100644
--- a/Userland/Utilities/CMakeLists.txt
+++ b/Userland/Utilities/CMakeLists.txt
@@ -56,3 +56,4 @@ target_link_libraries(gzip LibCompress)
target_link_libraries(gunzip LibCompress)
target_link_libraries(CppParserTest LibCpp LibGUI)
target_link_libraries(PreprocessorTest LibCpp LibGUI)
+target_link_libraries(file LibGfx LibIPC)