summaryrefslogtreecommitdiff
path: root/Userland/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanuele Torre <torreemanuele6@gmail.com>2021-01-22 07:31:06 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-22 11:29:52 +0100
commit5df714cd2272a1869fd397fae4b0c89acbf1a6c3 (patch)
tree47a14819b247779ba5b6e568566fa00c3c343101 /Userland/Utilities/CMakeLists.txt
parent7980268b7bd7274ab20f8e634f0191ad3f0b7c42 (diff)
downloadserenity-5df714cd2272a1869fd397fae4b0c89acbf1a6c3.zip
Build: Replace explicit use of mv(1) in CMake file with file(RENAME).
Also fix code style: `else ()` -> `else()`.
Diffstat (limited to 'Userland/Utilities/CMakeLists.txt')
-rw-r--r--Userland/Utilities/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Userland/Utilities/CMakeLists.txt b/Userland/Utilities/CMakeLists.txt
index 242754ac5d..9352734b1b 100644
--- a/Userland/Utilities/CMakeLists.txt
+++ b/Userland/Utilities/CMakeLists.txt
@@ -7,8 +7,8 @@ foreach(CMD_SRC ${CMD_SOURCES})
add_executable("${CMD_NAME}-bin" ${CMD_SRC})
target_link_libraries("${CMD_NAME}-bin" LibCore)
install(TARGETS "${CMD_NAME}-bin" RUNTIME DESTINATION bin)
- install(CODE "execute_process(COMMAND mv ${CMD_NAME}-bin ${CMD_NAME} WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/bin)")
- else ()
+ install(CODE "file(RENAME ${CMAKE_INSTALL_PREFIX}/bin/${CMD_NAME}-bin ${CMAKE_INSTALL_PREFIX}/bin/${CMD_NAME})")
+ else()
add_executable(${CMD_NAME} ${CMD_SRC})
target_link_libraries(${CMD_NAME} LibCore)
install(TARGETS ${CMD_NAME} RUNTIME DESTINATION bin)