summaryrefslogtreecommitdiff
path: root/Userland/Services/WindowServer/CMakeLists.txt
diff options
context:
space:
mode:
authorTom <tomut@yahoo.com>2021-06-20 13:23:43 -0600
committerAndreas Kling <kling@serenityos.org>2021-06-25 20:38:13 +0200
commit41859ad3feda56463ce0f73b898714ae17670ca6 (patch)
tree2592325a640c338620870c27fd16aee3174ef9ca /Userland/Services/WindowServer/CMakeLists.txt
parent42cb38b71a469c5b68280f9bc4b54a895781159d (diff)
downloadserenity-41859ad3feda56463ce0f73b898714ae17670ca6.zip
WindowServer: Add an Overlay class for flicker-free overlay rendering
An Overlay is similar to a transparent window, but has less overhead and does not get rendered within the window stack. Basically, the area that an Overlay occupies forces transparency rendering for any window underneath, which allows us to render them flicker-free. This also adds a new API that allows displaying the screen numbers, e.g. while the user configures the screen layout in DisplaySettings Because other things like drag&drop or the window-size label are not yet converted to use this new mechanism, they will be drawn over the screen-number currently.
Diffstat (limited to 'Userland/Services/WindowServer/CMakeLists.txt')
-rw-r--r--Userland/Services/WindowServer/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Services/WindowServer/CMakeLists.txt b/Userland/Services/WindowServer/CMakeLists.txt
index 4d9092ea49..3dd7c0be51 100644
--- a/Userland/Services/WindowServer/CMakeLists.txt
+++ b/Userland/Services/WindowServer/CMakeLists.txt
@@ -22,6 +22,7 @@ set(SOURCES
MenuItem.cpp
MenuManager.cpp
MultiScaleBitmaps.cpp
+ Overlays.cpp
Screen.cpp
ScreenLayout.cpp
Window.cpp