summaryrefslogtreecommitdiff
path: root/Userland/Services/WebServer/CMakeLists.txt
diff options
context:
space:
mode:
authorMax Wipfli <mail@maxwipfli.ch>2021-06-06 16:51:37 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-11 11:37:15 +0200
commite77ca79897ca47ebd6b36e4ba14995474afc84c3 (patch)
treea2361b2eaa6c7ee05499468dadce97edf23d0837 /Userland/Services/WebServer/CMakeLists.txt
parent2d18d3f329131cce7f91906c7c0e8cc45b9be31a (diff)
downloadserenity-e77ca79897ca47ebd6b36e4ba14995474afc84c3.zip
WebServer: Move server configuration into WebServer::Configuration
This moves the configuration of the web server, which currently only consists of the root path, into a new class, Configuration. Since the configuration is global and not per client, it is accessed by a singleton getter. This change simplifies future extensions of the configurable parameters.
Diffstat (limited to 'Userland/Services/WebServer/CMakeLists.txt')
-rw-r--r--Userland/Services/WebServer/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Services/WebServer/CMakeLists.txt b/Userland/Services/WebServer/CMakeLists.txt
index 34b1f037c9..5cb8b7384f 100644
--- a/Userland/Services/WebServer/CMakeLists.txt
+++ b/Userland/Services/WebServer/CMakeLists.txt
@@ -1,5 +1,6 @@
set(SOURCES
Client.cpp
+ Configuration.cpp
main.cpp
)