summaryrefslogtreecommitdiff
path: root/Userland/Services/FileSystemAccessServer/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy <timmot@users.noreply.github.com>2021-07-05 17:38:25 +1000
committerAndreas Kling <kling@serenityos.org>2021-07-10 15:33:46 +0200
commit41ce2debda1de75f80a4971afbf5ec7dcddf5ba3 (patch)
treeae0cf7374e624b880355fb72dbd9f9dccb87762d /Userland/Services/FileSystemAccessServer/CMakeLists.txt
parent5e823d3de0416461fe203143a1dbbb1530d351e8 (diff)
downloadserenity-41ce2debda1de75f80a4971afbf5ec7dcddf5ba3.zip
FileSystemAccessServer: Add service for accessing veiled files nicely
Adds new service FileSystemAccessServer which allows programs to request a file descriptor for any file on the file system. The user can be prompted to choose the path with a FilePicker, or the path can be provided by the application which will show a MessageBox showing the pid and name of the calling process and allows the user to approve or deny the request.
Diffstat (limited to 'Userland/Services/FileSystemAccessServer/CMakeLists.txt')
-rw-r--r--Userland/Services/FileSystemAccessServer/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Userland/Services/FileSystemAccessServer/CMakeLists.txt b/Userland/Services/FileSystemAccessServer/CMakeLists.txt
new file mode 100644
index 0000000000..67eeacb84a
--- /dev/null
+++ b/Userland/Services/FileSystemAccessServer/CMakeLists.txt
@@ -0,0 +1,18 @@
+serenity_component(
+ FileSystemAccessServer
+ REQUIRED
+ TARGETS FileSystemAccessServer
+)
+
+compile_ipc(FileSystemAccessServer.ipc FileSystemAccessServerEndpoint.h)
+compile_ipc(FileSystemAccessClient.ipc FileSystemAccessClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ main.cpp
+ FileSystemAccessServerEndpoint.h
+ FileSystemAccessClientEndpoint.h
+)
+
+serenity_bin(FileSystemAccessServer)
+target_link_libraries(FileSystemAccessServer LibCore LibIPC LibGUI)