summaryrefslogtreecommitdiff
path: root/Userland/Services/AudioServer/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-12 12:23:01 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-12 12:23:01 +0100
commitc7ac7e6eaff862c1ea4f99e0c6ce75e095106d9c (patch)
treece2a3fef96f0b8eebe907743f1e03739457c11a6 /Userland/Services/AudioServer/CMakeLists.txt
parent4055b0329117c1a280080bbd638eb48bafe29638 (diff)
downloadserenity-c7ac7e6eaff862c1ea4f99e0c6ce75e095106d9c.zip
Services: Move to Userland/Services/
Diffstat (limited to 'Userland/Services/AudioServer/CMakeLists.txt')
-rw-r--r--Userland/Services/AudioServer/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Userland/Services/AudioServer/CMakeLists.txt b/Userland/Services/AudioServer/CMakeLists.txt
new file mode 100644
index 0000000000..9c71197b62
--- /dev/null
+++ b/Userland/Services/AudioServer/CMakeLists.txt
@@ -0,0 +1,13 @@
+compile_ipc(AudioServer.ipc AudioServerEndpoint.h)
+compile_ipc(AudioClient.ipc AudioClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ Mixer.cpp
+ main.cpp
+ AudioServerEndpoint.h
+ AudioClientEndpoint.h
+)
+
+serenity_bin(AudioServer)
+target_link_libraries(AudioServer LibCore LibThread LibIPC)