summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-18 17:33:46 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-18 20:20:13 +0100
commitfd7920fa8f1deae5fb4b96c03d61c5e176cc12bc (patch)
treed65aa34380507aa87cbf45063781f7e2046d41de /Userland/Libraries/LibWeb/CMakeLists.txt
parentd18bc9ccd21d9bc03d67fca444886b5b18b9acd2 (diff)
downloadserenity-fd7920fa8f1deae5fb4b96c03d61c5e176cc12bc.zip
LibWeb: Add a very naive Layout::FlexFormattingContext :^)
This is very dumb and only lays out its child boxes on a horizontal line with their shrink-to-fit widths. You have to start somewhere! :^)
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index eef44ab9a1..1878872423 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -152,6 +152,7 @@ set(SOURCES
Layout/ButtonBox.cpp
Layout/CanvasBox.cpp
Layout/CheckBox.cpp
+ Layout/FlexFormattingContext.cpp
Layout/FormattingContext.cpp
Layout/FrameBox.cpp
Layout/ImageBox.cpp