summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-09-24 13:49:57 +0200
committerAndreas Kling <kling@serenityos.org>2021-09-24 15:12:15 +0200
commitf8dd3e14bae66bc9b3b26f4f896d9ca43f26e274 (patch)
treedd1c2eab045fa1d45fd298de7bddd98454157656 /Userland/Libraries/LibWeb/CMakeLists.txt
parent3dc6f0bc4718f5f54f2d18119a0f9fe457c283a8 (diff)
downloadserenity-f8dd3e14bae66bc9b3b26f4f896d9ca43f26e274.zip
LibWeb: Rename CSS::StyleResolver => StyleComputer
Resolved style is a spec concept that refers to the weird mix of computed style and used style reflected by getComputedStyle(). The purpose of this class is to produce the *computed* style for a given element, so let's call it StyleComputer.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index 358c4a1ff3..5a6d89af48 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -31,9 +31,9 @@ set(SOURCES
CSS/Screen.cpp
CSS/Selector.cpp
CSS/SelectorEngine.cpp
+ CSS/StyleComputer.cpp
CSS/StyleInvalidator.cpp
CSS/StyleProperties.cpp
- CSS/StyleResolver.cpp
CSS/StyleSheet.cpp
CSS/StyleSheetList.cpp
CSS/StyleValue.cpp