summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-10-18 11:53:40 -0400
committerAndreas Kling <kling@serenityos.org>2021-10-18 23:33:56 +0200
commitd24ae8063b154c997c91ff004d668ed16d1b4a7f (patch)
tree209b933ea9c7bd26c85cacf23736d925c58e0445 /Userland/Libraries/LibWeb/CMakeLists.txt
parent4d8320a49a0e35843ed94414c227389adcf03689 (diff)
downloadserenity-d24ae8063b154c997c91ff004d668ed16d1b4a7f.zip
LibWeb: Implement DOMTokenList for managing space-separated tokens lists
DOMTokenList is used as the return type of, e.g., the Element.classList property.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index 92028e30f6..5334e05ec6 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -61,6 +61,8 @@ set(SOURCES
DOM/Comment.cpp
DOM/CustomEvent.cpp
DOM/DOMImplementation.cpp
+ DOM/DOMTokenList.cpp
+ DOM/DOMTokenList.idl
DOM/Document.cpp
DOM/DocumentFragment.cpp
DOM/DocumentLoadEventDelayer.cpp
@@ -380,6 +382,7 @@ libweb_js_wrapper(DOM/DocumentFragment)
libweb_js_wrapper(DOM/DocumentType)
libweb_js_wrapper(DOM/DOMException)
libweb_js_wrapper(DOM/DOMImplementation)
+libweb_js_wrapper(DOM/DOMTokenList)
libweb_js_wrapper(DOM/Element)
libweb_js_wrapper(DOM/Event)
libweb_js_wrapper(DOM/EventTarget)