summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Atkins <atkinssj@serenityos.org>2023-03-30 16:57:49 +0100
committerAndreas Kling <kling@serenityos.org>2023-03-30 21:29:50 +0200
commitfa90a3bb4fc3e4a8a0caa0b80a7ac87765ab67f9 (patch)
tree2d6acd146dcc1107c56d6a28d2da6d69ddde1f3b /Userland/Libraries/LibWeb/CMakeLists.txt
parentb727f8113f9280e64e18dcbb0ed2921b19e51083 (diff)
downloadserenity-fa90a3bb4fc3e4a8a0caa0b80a7ac87765ab67f9.zip
LibWeb: Introduce CalculatedOr type
This is intended as a replacement for Length and friends each holding a `RefPtr<CalculatedStyleValue>`. Instead, let's make the types explicit about whether they are calculated or not. This then means a Length is always a Length, and won't require including `StyleValue.h`. As noted, it's probably nicer for LengthOrCalculated to live in `Length.h`, but we can't do that until Length stops including `StyleValue.h`.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index b4fb86ac21..2cd4effbcf 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -16,6 +16,7 @@ set(SOURCES
Crypto/Crypto.cpp
Crypto/SubtleCrypto.cpp
CSS/Angle.cpp
+ CSS/CalculatedOr.cpp
CSS/Clip.cpp
CSS/CSS.cpp
CSS/CSSConditionRule.cpp