summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-04-03 11:43:08 +0200
committerAndreas Kling <kling@serenityos.org>2021-04-03 11:57:32 +0200
commitdcfc357860a365c190599fca6891d845b61e6a5b (patch)
tree804b1b60515b50b67acc4f77dfa760fb6c1d964a /Userland/Libraries/LibWeb/CMakeLists.txt
parent8e3e3a71cb20ba4a743cd4ad2dcec49a31f35733 (diff)
downloadserenity-dcfc357860a365c190599fca6891d845b61e6a5b.zip
LibWeb: Add a FrameHostElement for frame/iframe common functionality
A FrameHostElement is an HTML element (<frame> or <iframe>) that may have a content frame that participates in the frame tree. This basically just moves code from <iframe> to a separate base class so we can share it with <frame> once we implement <frame>.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index 4f57a2c46b..fc6adc0552 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -64,6 +64,7 @@ set(SOURCES
HTML/AttributeNames.cpp
HTML/CanvasRenderingContext2D.cpp
HTML/EventNames.cpp
+ HTML/FrameHostElement.cpp
HTML/GlobalEventHandlers.cpp
HTML/HTMLAnchorElement.cpp
HTML/HTMLAreaElement.cpp