summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-02-03 20:08:27 +0100
committerAndreas Kling <kling@serenityos.org>2022-02-03 22:35:13 +0100
commitdc3bf32307085fee3cbbedfeb72ee10dc130d04c (patch)
treed8be0fdebbf165508ceede3789d50f855a0d313c /Userland/Libraries/LibWeb/CMakeLists.txt
parent545ec334f00791c39b0e7497a89e9e5001336c0e (diff)
downloadserenity-dc3bf32307085fee3cbbedfeb72ee10dc130d04c.zip
LibWeb: Add barebones CanvasGradient object
Also add the CanvasRenderingContext2D APIs to go along with it. Note that it can't be used for anything yet.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index 3204cc484f..1f62f6bccb 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -99,6 +99,7 @@ set(SOURCES
HTML/AttributeNames.cpp
HTML/BrowsingContext.cpp
HTML/BrowsingContextContainer.cpp
+ HTML/CanvasGradient.cpp
HTML/CanvasRenderingContext2D.cpp
HTML/DOMParser.cpp
HTML/DOMStringMap.cpp
@@ -406,6 +407,7 @@ libweb_js_wrapper(DOM/Text)
libweb_js_wrapper(Encoding/TextEncoder)
libweb_js_wrapper(Geometry/DOMRect)
libweb_js_wrapper(Geometry/DOMRectReadOnly)
+libweb_js_wrapper(HTML/CanvasGradient)
libweb_js_wrapper(HTML/CanvasRenderingContext2D)
libweb_js_wrapper(HTML/CloseEvent)
libweb_js_wrapper(HTML/DOMParser)