summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Wilde <lukew@serenityos.org>2021-10-02 20:33:45 +0100
committerAndreas Kling <kling@serenityos.org>2021-10-03 00:18:52 +0200
commit8d6db36cbb8279effe2b3d83a93798e6de5685fc (patch)
treef00f8a9e871e4cf19153ceae5fa2e224a0173830 /Userland/Libraries/LibWeb/CMakeLists.txt
parentbfd089fbd1e9bc0c088b4781550dde8c3ad96da2 (diff)
downloadserenity-8d6db36cbb8279effe2b3d83a93798e6de5685fc.zip
LibWeb: Add support for NodeList
This introduces 3 classes: NodeList, StaticNodeList and LiveNodeList. NodeList is the base of the static and live versions. Static is a snapshot whereas live acts on the underlying data and thus inhibits the same issues we have currently with HTMLCollection. They were split into separate classes to not have them weirdly mis-mashed together. The create functions for static and live both return a NNRP to the base class. This is to prevent having to do awkward casting at creation and/or return, as the bindings expect to see the base NodeList only.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index b2e36a510a..d4de8dfde7 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -66,12 +66,14 @@ set(SOURCES
DOM/EventListener.cpp
DOM/EventTarget.cpp
DOM/HTMLCollection.cpp
+ DOM/LiveNodeList.cpp
DOM/Node.cpp
DOM/ParentNode.cpp
DOM/Position.cpp
DOM/ProcessingInstruction.cpp
DOM/Range.cpp
DOM/ShadowRoot.cpp
+ DOM/StaticNodeList.cpp
DOM/Text.cpp
DOM/Text.idl
DOM/Timer.cpp
@@ -371,6 +373,7 @@ libweb_js_wrapper(DOM/HTMLCollection)
libweb_js_wrapper(DOM/ProcessingInstruction)
libweb_js_wrapper(DOM/ShadowRoot)
libweb_js_wrapper(DOM/Node)
+libweb_js_wrapper(DOM/NodeList)
libweb_js_wrapper(DOM/Range)
libweb_js_wrapper(DOM/Text)
libweb_js_wrapper(Geometry/DOMRect)