summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-02-08 19:38:29 +0100
committerAndreas Kling <kling@serenityos.org>2022-02-08 21:53:20 +0100
commit47979996e832bdd05440c4a9437920863543441d (patch)
tree0e8e11301a4ef39146f5752dc323ac05297a409a /Userland/Libraries/LibWeb/CMakeLists.txt
parenta856cf8d4c92b56b651e87df604f4d04a6e977dd (diff)
downloadserenity-47979996e832bdd05440c4a9437920863543441d.zip
LibWeb: Add Storage interface and window.localStorage
This is a naive-but-somewhat-functional initial implementation of HTML Storage. Note that there is no persistence yet, everything is in-process only, and one local Storage object per origin.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index d567364dce..762a2c96ac 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -196,6 +196,7 @@ set(SOURCES
HTML/Scripting/ExceptionReporter.cpp
HTML/Scripting/Script.cpp
HTML/Scripting/WindowEnvironmentSettingsObject.cpp
+ HTML/Storage.cpp
HTML/SyntaxHighlighter/SyntaxHighlighter.cpp
HTML/TagNames.cpp
HTML/TextMetrics.cpp
@@ -493,6 +494,7 @@ libweb_js_wrapper(HTML/MessageEvent)
libweb_js_wrapper(HTML/MessagePort)
libweb_js_wrapper(HTML/PageTransitionEvent)
libweb_js_wrapper(HTML/PromiseRejectionEvent)
+libweb_js_wrapper(HTML/Storage)
libweb_js_wrapper(HTML/SubmitEvent)
libweb_js_wrapper(HTML/TextMetrics)
libweb_js_wrapper(HTML/WebSocket)