summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-03-14 17:05:02 +0100
committerAndreas Kling <kling@serenityos.org>2021-03-15 21:20:33 +0100
commit4559faf8d879eb18d2b5729c19d3af9c6482d39f (patch)
treeb6af0fa88c9067d19efa77fbf9685ad941fb3e39 /Userland/Libraries/LibWeb/CMakeLists.txt
parentab23ef92b6809a4cc76599840d977a0c77f3de2c (diff)
downloadserenity-4559faf8d879eb18d2b5729c19d3af9c6482d39f.zip
LibWeb: Support named CSS properties on CSSStyleDeclaration wrapper
Use the new CustomGet/CustomPut wrapper mechansim to intercept gets and puts on CSSStyleDeclaration objects. This allows content to get and set individual CSS properties from JavaScript. :^)
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index 4b062f0118..f183d154aa 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -1,4 +1,5 @@
set(SOURCES
+ Bindings/CSSStyleDeclarationWrapperCustom.cpp
Bindings/EventListenerWrapper.cpp
Bindings/EventWrapperFactory.cpp
Bindings/EventTargetWrapperFactory.cpp