summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-02-05 15:19:16 +0100
committerAndreas Kling <kling@serenityos.org>2022-02-05 22:50:39 +0100
commit04bec7a4f53ecd13673d6ea1acdb172abadc4b2c (patch)
tree28b9500b57e3c56c7be37d5187c798b78f5cda76 /Userland/Libraries/LibWeb/CMakeLists.txt
parente6f279dadaebbdb032a8f45a34dbafeb48a593c4 (diff)
downloadserenity-04bec7a4f53ecd13673d6ea1acdb172abadc4b2c.zip
LibWeb: Remove CSS::StyleInvalidator in favor of dirtying + lazy update
Style updates are lazy since late last year, so the StyleInvalidator is actually hurting us more than it's helping by running the entire CSS selector machine on the whole DOM for every attribute change. Instead, simply mark the entire DOM dirty and let the lazy style update mechanism run *once* on next event loop iteration.
Diffstat (limited to 'Userland/Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibWeb/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Userland/Libraries/LibWeb/CMakeLists.txt b/Userland/Libraries/LibWeb/CMakeLists.txt
index f8d7d10cf3..7451212877 100644
--- a/Userland/Libraries/LibWeb/CMakeLists.txt
+++ b/Userland/Libraries/LibWeb/CMakeLists.txt
@@ -46,7 +46,6 @@ set(SOURCES
CSS/Selector.cpp
CSS/SelectorEngine.cpp
CSS/StyleComputer.cpp
- CSS/StyleInvalidator.cpp
CSS/StyleProperties.cpp
CSS/StyleSheet.cpp
CSS/StyleSheetList.cpp