summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibVideo/CMakeLists.txt
diff options
context:
space:
mode:
authorZaggy1024 <zaggy1024@gmail.com>2022-10-08 21:54:20 -0500
committerAndrew Kaster <andrewdkaster@gmail.com>2022-10-09 20:32:40 -0600
commit1514004cd59798f9e2eeb44f381d78a9c1caa877 (patch)
tree421351cab9737fe23424d8f0b2d0ce41f0125d38 /Userland/Libraries/LibVideo/CMakeLists.txt
parentda9ff3116681800d0d6ed7c6a1e62c5b91df1264 (diff)
downloadserenity-1514004cd59798f9e2eeb44f381d78a9c1caa877.zip
LibVideo: Implement VP9 intra-predicted frame decoding
The first keyframe of the test video can be decoded with these changes. Raw memory allocations in the Parser have been replaced with Vector or Array to avoid memory leaks and OOBs.
Diffstat (limited to 'Userland/Libraries/LibVideo/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibVideo/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Userland/Libraries/LibVideo/CMakeLists.txt b/Userland/Libraries/LibVideo/CMakeLists.txt
index 293a106d77..ec1a4f517b 100644
--- a/Userland/Libraries/LibVideo/CMakeLists.txt
+++ b/Userland/Libraries/LibVideo/CMakeLists.txt
@@ -7,8 +7,7 @@ set(SOURCES
VP9/ProbabilityTables.cpp
VP9/SyntaxElementCounter.cpp
VP9/TreeParser.cpp
- VP9/Utilities.cpp
)
serenity_lib(LibVideo video)
-target_link_libraries(LibVideo LibAudio LibCore LibIPC)
+target_link_libraries(LibVideo LibAudio LibCore LibIPC LibGfx)