summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibSQL/CMakeLists.txt
diff options
context:
space:
mode:
authorJan de Visser <jan@de-visser.net>2021-11-02 16:43:57 -0400
committerAndreas Kling <kling@serenityos.org>2021-11-10 14:47:49 +0100
commit1c50e9aadcb16ac5963013444392bab21155bad3 (patch)
tree7345579c333cdec625667f13ad2bd69d2f654920 /Userland/Libraries/LibSQL/CMakeLists.txt
parent7ea54db43062a15615735eda2b23c214cc7a0d1a (diff)
downloadserenity-1c50e9aadcb16ac5963013444392bab21155bad3.zip
LibSQL: Add current statement to the ExecutionContext
Because SQL is the craptastic language that it is, sometimes expressions need to know details about the calling statement. For example the tables in the 'FROM' clause may be needed to determine which columns are referenced in 'WHERE' expressions. So the current statement is added to the ExecutionContext and a new 'execute' overload on Statement is created which takes the Database and the Statement and builds an ExecutionContaxt from those.
Diffstat (limited to 'Userland/Libraries/LibSQL/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibSQL/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Userland/Libraries/LibSQL/CMakeLists.txt b/Userland/Libraries/LibSQL/CMakeLists.txt
index 744d7980aa..1bfa86baa1 100644
--- a/Userland/Libraries/LibSQL/CMakeLists.txt
+++ b/Userland/Libraries/LibSQL/CMakeLists.txt
@@ -6,6 +6,7 @@ set(SOURCES
AST/Lexer.cpp
AST/Parser.cpp
AST/Select.cpp
+ AST/Statement.cpp
AST/SyntaxHighlighter.cpp
AST/Token.cpp
BTree.cpp