summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibProtocol/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-01-12 12:17:30 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-12 12:17:46 +0100
commit13d7c09125f8eec703d0a43a9a87fc8aa08f7319 (patch)
tree70fd643c429cea5c1f9362c2674511d17a53f3b5 /Userland/Libraries/LibProtocol/CMakeLists.txt
parentdc28c07fa526841e05e16161c74a6c23984f1dd5 (diff)
downloadserenity-13d7c09125f8eec703d0a43a9a87fc8aa08f7319.zip
Libraries: Move to Userland/Libraries/
Diffstat (limited to 'Userland/Libraries/LibProtocol/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibProtocol/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Userland/Libraries/LibProtocol/CMakeLists.txt b/Userland/Libraries/LibProtocol/CMakeLists.txt
new file mode 100644
index 0000000000..7c2e59d45d
--- /dev/null
+++ b/Userland/Libraries/LibProtocol/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(SOURCES
+ Client.cpp
+ Download.cpp
+)
+
+set(GENERATED_SOURCES
+ ../../Services/ProtocolServer/ProtocolClientEndpoint.h
+ ../../Services/ProtocolServer/ProtocolServerEndpoint.h
+)
+
+serenity_lib(LibProtocol protocol)
+target_link_libraries(LibProtocol LibIPC)