summaryrefslogtreecommitdiff
path: root/Userland/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-02-07 16:56:02 +0100
committerAndreas Kling <kling@serenityos.org>2021-02-07 16:56:02 +0100
commitddbf20ecf6c1e359a3b9f7c5ba7e0b5f3eec2f4d (patch)
treed55897c4c002ff69b34d9e79962055912bb1eb79 /Userland/Libraries/LibJS/CMakeLists.txt
parent22baa5e64fdd60b780beef785fd76ad1bd70f9bf (diff)
downloadserenity-ddbf20ecf6c1e359a3b9f7c5ba7e0b5f3eec2f4d.zip
LibSyntax+LibGUI+LibJS: Move JS syntax highlighter to LibJS
This is a little bit messy but the basic idea is: Syntax::Highlighter now has a Syntax::HighlighterClient to talk to the outside world. It mostly communicates in LibGUI primitives that are available in headers, so inlineable. GUI::TextEditor inherits from Syntax::HighlighterClient. This let us to move GUI::JSSyntaxHighlighter to JS::SyntaxHighlighter and remove LibGUI's dependency on LibJS.
Diffstat (limited to 'Userland/Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Userland/Libraries/LibJS/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Userland/Libraries/LibJS/CMakeLists.txt b/Userland/Libraries/LibJS/CMakeLists.txt
index 5d149be98e..5f5329cb5d 100644
--- a/Userland/Libraries/LibJS/CMakeLists.txt
+++ b/Userland/Libraries/LibJS/CMakeLists.txt
@@ -81,8 +81,9 @@ set(SOURCES
Runtime/VM.cpp
Runtime/Value.cpp
Runtime/WithScope.cpp
+ SyntaxHighlighter.cpp
Token.cpp
)
serenity_lib(LibJS js)
-target_link_libraries(LibJS LibM LibCore LibCrypto LibRegex)
+target_link_libraries(LibJS LibM LibCore LibCrypto LibRegex LibSyntax)